PDA

View Full Version : Prince of Persia - Two Thrones


SFFWorld.com
Home - Discussion Forums - News - Reviews - Interviews

New reviews, interviews and news

New in the Discussion Forum


Pages : [1] 2

The Full Octave
January 2nd, 2006, 05:39 PM
I looked over the previous postings and I cant see a thread on this but if there is apologises. I was given it as a present. Now I am not a big gamer, in fact I am not even a small gamer, but none the less I went and start playing away. I reached the first boss and well, the Speed Kill option that should fire when I jump onto his shoulder never does. I feel this is a error in the game. Anyone else have this problem. It is really annoying me as it is stopping me progress. I have tried it probably near on 60 times. Nothing.

Any help?

Gareth

Tarn
January 9th, 2006, 05:20 AM
I'm not sure the speed kill occurs straight away, sometimes a small animation plays with you swinging about before the speed kill hits. Sometimes it can be hard to spot with so much going on.

The Full Octave
January 10th, 2006, 04:55 AM
Its next near impossible then cos I have tried and tried. I am not bad at the game but If I am missing it the amount of times I tried then I must be brutal. I am playing on a HUGE screen too. It should be easier to see.

Tarn
January 10th, 2006, 04:59 AM
Hm, odd, it was fairly easy here (or, at least, easy to spot the 'speed kill' alert). Perhaps something strange has happened to your game, although I can't imagine what.

Dean
January 13th, 2006, 04:17 PM
On mine it appears RIGHT AWAY as you're in the air but if you've tried it that many times it might be a fault in the game then like you said.

The Full Octave
January 14th, 2006, 09:36 AM
are you all on ps2? I walk onto the plank, and I get the speed kill. It jumps me and in the air my knife glows. I stab his shoulder. Now, from one side, I fall and he grabs me and in his hand I raise my knife but thats it, no speed kill and I am flung.

The other side, I move a little but then he plucks me up and throws me. I do not see speed kill again after the inital one. I read on a few boards since a few people have this problem and the games company are refusing to reply ot emails. Its a pain in the ar$e

Dean
January 14th, 2006, 02:48 PM
I'm on ps2 but I managed to do it after a while, when you're on his back it's hard to see the knife flash because their's alot going on and the screen is all fuzzy and stuff, but I would try doing it but keep focusing on the knife (if you havent already done that which you probably have) other than that it probably is a fault in your game, but i'll play it again and try to describe to you the precise moment the knife flashes. Have you cheked any walkthroughs or anything for info on when the knife flashes to see if that helps?

The Full Octave
January 15th, 2006, 03:23 PM
Yeah I have checked about the place. I have a huge screen and I can't see the flash at all. I have done this probably 100 times now. Its a pain.

Dean
January 18th, 2006, 02:49 PM
I've checked around walkthroughs for you and i've tried it myself and these are when the speed kill knife flashes in the speed kill that should start when you are on the beam happen.The first one happens when you dive out, the second happens when you are in his hand and the third happens when you are on his face. If, like you said nothing happens when you are in his hand then it's a problem with the game because it's definately supposed to flash then. Hope this helps. ;)

The Full Octave
January 23rd, 2006, 11:58 AM
I was giving up and I thought to myself this cant be right. The game would of been tested so I turned off radios and any noises I sat a metre from the large screen and tried it. I was in his hand and I managed to press the button (no flashes or sounds alerted me) and I stabbed him. Once this happened I realised it was possible and amazingly I did the entire thing in two go's or so after. So it was me just being a crap gamer :)

I am well happy. Cheers dean and others who assisted me :)