PDA

View Full Version : Timesplitters Future Perfect help pleeeease!!


SFFWorld.com
Home - Discussion Forums - News - Reviews - Interviews

New reviews, interviews and news

New in the Discussion Forum


happykat826
January 3rd, 2007, 08:23 PM
I gave the game to hubby for Christmas. He really enjoys it and many similar. His medication makes some of these a bit hard and I spend a lot of time reading FAQs for him when the next step or way out of something is not so obvious.

Right now we are just plain stuck. And I am at a loss of how to help him.
It is at the end of chapter 2 or is it chapter 3 where you have to find the train and blast through doors. After the cut scene the last door will not open. All objectives are completed and nothing works. We have tried shooting, running, grenades and everything. We:( drove the jeep through the blast door that I opened with the shell, killed the four people, then on the stairs killed the three people. You walk to the corner and a cut scene appears. The time traveler leaps thru but leaves two people for you to kill. All ( and I have read soooooo many) say just walk through the last door. Well, it won't open.. the train is there. You cannot go back so you are stuck staring at the door. No FAQ gives any descriptions of how the door is supposed to open or if something is needed to open it. All other details of the many FAQs we read follow our game play to a tee. We cannot figure out what we are missing or not doing. Again, all objectives are completed in order, there is no where else to go. The uplink doesn't work on the door either.
We have replayed the whole chapter two or three times and from the check point and cut scene for over two hours. we ran at the door and just stood at the door and waited. Please help!!!! This is a cool game but very frustrating at this time.
How does the pass/id/badge play into this? Maybe that is what he is missing. I thought that just let him turn on the power. Hubby is too pissed to play it again right now but he has no pass card in his inventory, but I saw it on the screen once.
Thanks so much for any and all help .. We love EA games - this is the first one to give us trouble.

kater
January 4th, 2007, 10:50 AM
I haven't personally played the game but the best FAQ I could find for you is here: http://db.gamefaqs.com/console/ps2/file/timesplitters_3_b.txt The level sounds like the Russian Connection (Level 3) and it suggests that to open the door

"You'll come across a locked blast door which you'll have to "open" manually. Leave the car here and head further up the tunnel on foot until you see a blast door on your left. This will open to reveal a firing range. There's a box of grenades on the shelf by the wall, but what you need is sitting at the end of a conveyor on the right wall: a tank shell. Pick this up with the uplink and carry it back to the door. Throw the shell at the door to blow it up. If you miss or drop the shell, you'll have to go back and pull the lever on the conveyor to get another one. Get back in the car and head up the tunnel."

Hope this helps :)

happykat826
January 6th, 2007, 11:34 AM
There are 4 doors in all. One door is full of men and has the world domination plans in it - not necessary to go in here but there is health pak and grenades - we have tried both going in and just leaving it shut and not dealing with the men at all.
The second door opens by banging into it with the jeep, although it may open other ways too. That is where the shell is. That shell makes a hole in the third door marked Restricted Area and the hole is large enought to drive the jeep through. It is your choice to drive thru and run over 4 men or shoot them or walk thru and shoot them. After they are dead, you go down a few flights of metal stairs shooting three more guys. Next, you go down the tunnel hallway to a corner and a cut scene comes on. The time traveler is leaving through a time warp hole thingy. He leaves two men to shoot you and disappears, the warp closes. You shoot two men. ANDDDDD then

the last sentence of every FAQ says, walk thru the door. That would be the forth door - It won't open and that is the end of the chapter. The next one should/would start with you jumping on the train you were looking for. Because the cut scene invokes a checkpoint, you cannot go back to any rooms. We have tried up to 5 grenades and they don't work. In other words we wander an empty hallway between two steel doors - one of which is supposed to open.

EA says maybe corrupted save data - everyone else says read faqs. EA has no forum for this game. WE have played it over three times and exchanged the game at the store.
We will most likely start over and use a different memory card -

I appreciate everyones help.. I must not have been clear that we are past the door where you have to use the shell to blow it up.
Thanks again

kater
January 6th, 2007, 04:48 PM
No problems, good luck :D