Not sure if this is the correct place to post this, but whilst searching for topics earlier today, I got the following error message:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@sffworld.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Apache/2.2.9 (Unix) mod_ssl/2.2.9 OpenSSL/0.9.7a mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 PHP/5.2.6 Server at www.sffworld.com Port 80
It happened after I'd searched for the keywords newton's cannon in the search box on the forum index. When I was taken to the results page, I got the error message when clicking on the topic result links.

I noticed that when I changed the url of the topics listed in my search results from http://www.sffworld.com/forums/showt...#37;27s+cannon to http://www.sffworld.com/forums/showthread.php?t=10365 the error was resolved and I was able to view the page in question. (So I'm wondering if it's the ' in my search that's throwing things out.)

Anyways, just thought I'd mention it. Never had this problem before when searching, and the rest of the boards seem to be fine, so I wondered if it was some pesky little bug that no one's found before.